概要
TimeTracker NX 操作時に新規でデータを追加することはできますが、
既存のデータの更新や削除をすると以下のエラーが表示される場合があります。
■エラーメッセージ
■対象のデータ
ユーザー、組織など多岐にわたります。
上記エラー発生時の原因と対応方法をご案内します。
原因
IISの設定で、WebDAVがインストールされている場合、PUT(更新)およびDELETE(削除)の要求が許可されなくなります。
確認方法
以下の手順にて「WebDAV」がインストールされているか確認できます。
- 「コントロール パネル」>「プログラム」>「プログラムと機能」を起動する。
- [プログラムと機能]ダイアログで[Windowsの機能の有効化または無効化]をクリックする。
- 表示されるダイアログのツリーにて、以下にチェックが入っているかを確認する 。
・[インターネットインフォメーションサービス]>[World Wide Webサービス]>[HTTP共通機能]>[WebDAV発行]
※チェックが入っていた場合は「インストールされている」となります。
対応方法
上記の「確認方法」で[WebDAV発行]のチェックを外してください。
IISの設定でTimeTracker NX のみを無効化することもできますが、無効化しても問題が解決しない事例がございました。
確実に上記ご対応をお願い致します。