対象バージョン
本記事の更新は終了しています。
最新版は「TimeTracker NX コミュニティサイト」を参照ください。
TimeTracker NX 4.5以降 (Standard/Professional Edition)
対象
ExcelからのWBSコピー機能
概要
TimeTracker NXでは、Excelで作成したWBSをコピー&ペーストで簡単にプロジェクトに追加することができますが、さまざまな理由によりWBSをコピーできない場合があります。
本ページでは、コピーできない原因をケースごとにご紹介します。
ケース1
原因
ご利用の環境により、ExcelからWBSのコピーをすることができない場合があります。
(ブラウザの制約になります。)
以下の条件にあてはまらないかご確認ください。
- TimeTracker NXへのアクセス方法:HTTP
回避方法
アクセス方法をHTTPSに変更してください。
HTTPSへの切り替え方法については、以下のナレッジベースを参照してください。
■セキュリティを強化するためHTTPS通信に切り替える
<https://dcinchelp.zendesk.com/hc/ja/articles/360044708173>
ケース2
原因
ブラウザでクリップボードへのアクセスを許可していない場合が考えられます。
TimeTrakcer NX 上で初めてアイテムのコピー操作をするときに、
『クリップボードを許可するかどうか』を尋ねるポップアップが出ます。
ここで許可しないと、現象が発生します。
回避方法
上記のポップアップが出たときに『許可』としてください。
後から許可にすることもできまずが、お使いのブラウザにより設定方法が異なります。
ご確認の上、設定を変更してください。
ケース3
原因
Excelで作成したWBSや指定方法に間違いがある場合が考えられます。
以下の内容に合致しないかご確認ください。
- 実績工数が入力されているワークアイテムを親のアイテムに指定している。
- 同一階層にワークアイテムを1000以上設定している。
※この場合、1000を超えるワークアイテムは追加されません。 - 16階層を超える階層を設定している。
※16階層以降のワークアイテムは追加されません。 - ワークアイテムに名前が指定されていない。
- 親アイテムの作成に失敗している。
※その親の子アイテムは追加されません。
回避方法
Excelで作成したWBSに間違いがある場合は、WBSを修正してください。
詳細な定義は以下のページを参照してください。
■ExcelからWBSをコピーする場合の注意事項
<https://www.timetracker.jp/support/help/document/reference/excel_copy_notes.html>
ケース4
原因
対象のプロジェクトを編集モードで開いていないためにコピーできない場合があります。
以下の理由が考えられるのでご確認ください。
- プロジェクトがロックされている場合(デスクトップ版と併用の場合のみ)
- 対象プロジェクトを編集する権限が無い場合
回避方法
デスクトップ版で開いている場合は、デスクトップ版でプロジェクトを閉じます。
プロジェクトの編集権限がない場合は、アカウントのシステムロールやプロジェクトのセキュリティにて、プロジェクトの編集権限を付与します。