概要
プロジェクトを作成したユーザーでも、そのプロジェクトが一覧に表示されず、プロジェクトを開いて閲覧や編集ができない場合があります。
このページでは、その原因ならびに解決方法について紹介します。
このページでは、その原因ならびに解決方法について紹介します。
原因
プロジェクトが存在するのにも関わらず一覧に表示されない、あるいはプロジェクトの閲覧や編集ができないのは、そのプロジェクトへのアクセス権限がないことが原因です。
権限は管理者向け画面(Admin)の「システムロール」で設定するのですが、初期状態のままだと標記の状態になることがあります。
システムロールによる権限設定においては、「権限」により使用可能な機能が、「アクセス範囲」により操作可能なデータの範囲が決まります。
初期状態では、「プロジェクトの閲覧」・「プロジェクトの編集」それぞれの権限のアクセス範囲は「個々のプロジェクトで設定」となっています。この場合、デフォルトではプロジェクトの一覧に表示されずプロジェクトを開くことができません。
対処方法
プロジェクトを作成したユーザーに割り当てられているシステムロールを確認し、そのユーザーに合ったアクセス範囲を設定します。
システムロールの設定方法については、[システムロールを管理する]をご覧ください。
- 設定例1:管理者(すべてのプロジェクトを対象に編集できるようにする)
すべてのプロジェクトを対象に編集できるようにするには、アクセス範囲に「すべて」を設定します。
- 設定例2:マネジャー(所属している組織のプロジェクトを対象に編集できるようにする)
所属している組織のプロジェクトを対象に編集できるようにするには、アクセス範囲に「所属組織以下のプロジェクト」を設定します。 - 設定例3:担当者(特定のプロジェクトのみを対象に編集できるようにする)
担当している特定のプロジェクトのみを対象に編集できるようにするには、アクセス範囲に「個々のプロジェクトで設定」を設定します。その場合は、対象プロジェクトにアクセスするユーザーをセキュリティに設定し、「プロジェクトの編集」権限を許可する必要があります。
セキュリティの設定方法については、[メンバーの権限を設定する]をご覧ください。